MacNN points to an Apple Support document announcing Boot Camp will cease to work “when Leopard is available to the public.” That means if you’re happily dual-booting Linux or Windows on your Mac, you may soon be unable to do so without a Leopard upgrade. Edit: This is technically inaccurate as written originally. What Apple says is that “The license to use Boot Camp Beta expires when Mac OS X 10.5 Leopard is available to the public. To continue using Boot Camp at that time, upgrade to Mac OS X 10.5 Leopard.” So, in other words, portions should still work (the boot loader itself), but the license is no longer valid and the assistant will no longer function. It’s still unclear when the assistant ceases function, but it seems to be that its termination date, as baked into the assistant software, is December 31, 2007. That means you should be able to continue running Boot Camp indefinitely, even if it technically violates your license, and use the assistant until the end of the year (we think). If necessary, you may need to keep lawyers away from your desk. If you have beta 1.2 or earlier, the assistant software has already expired, though the bootloader should not. The 1.3/1.4 beta should expire soon, upon release of the new OS. -PK

This is especially bad news for music users, who almost never upgrade operating systems the day they ship because of compatibility and support issues. (Sure, Logic will support Leopard from day one … and your audio interface will be around in, what, three months, with Pro Tools months later?)

Close reading of the user agreement in Boot Camp beta had given some users warning of this some time ago, which is prompting hordes of Apple apologists to somehow argue this is a good idea. I salute you for your positive outlook, but this seems awfully annoying otherwise (even if right now I’m keeping XP only on my PC boxes.)

Given that Boot Camp has been a huge publicity score for Apple, I’m hopeful Apple will reconsider, offering Boot Camp for Tiger at least as an unsupported download, or at least give Tiger users a grace period in which they can upgrade to the new OS. Yes, it’s a beta … but it’s a beta of Boot Camp, not Leopard per se, and it’s working for people, often a selling point for hardware and software far more profitable to Apple than the OS upgrade is. And because Boot Camp is really great, and Leopard promises lots of additional awesomeness beyond Boot Camp, it seems unlikely that people will need a self-destruct sequence in Boot Camp just to get them to upgrade.

On a bright note, at least Linux dual-booters have other options… and there’s always Parallels and VMWare.

Apple warns of Boot Camp expiration [MacNN]
When does Boot Camp Beta expire? [Apple.com Support, in a document curiously not answering when that is beyond obliquely suggesting "October 2007"]

Update: R Eunson and others point out some details Apple left out of their support document: only the Boot Camp Assistant should stop working, not the bootloader that lets you choose operating systems.

I still say, though, this isn’t exactly one for Great Moments in Customer Support. Is it a deal-breaking, press-stopping issue? No, of course not. But it’s niggling issues where customer satisfaction is won or lost — the difference between 9/10 and 10/10. We focus a lot on quality in terms of technical quality assurance — whether engineering got the code / gear working right. But a lot of cases actually come down to communications and support. Here, Apple could make basically the exact same decision, but communicate more effectively (a user license is not an effective communications tool) and clearly (telling you when the app stops working, not your legal license). I’m not trying to single out Apple here, by any means. This is something all tech companies could do better, not because they have to or because their business requires it, but because they’ll have happier customers. And happy customers do spend more money.

  • Adrian Anders

    Let me say, on behalf of all PC users who have been taunted by Apple fanbois about "bootcamp this, bootcamp that"….

    P3WND!

  • Claudio

    Didn't Apple say WAAAY back when before the release of the iPhone that Boot Camp was going to cost Tiger users $30 once it was finally released? Apple had given people the choice of either upgrading to Leopard and getting the final version of Boot Camp included or sticking with Tiger and paying for the final version of Boot Camp.

    http://www.macscoop.com/articles/2007/01/20/apple

    Even still, I personally don't think a bootloader should cost 30 bucks. Ah well. There's always elilo and it's free. :-)

    http://elilo.sourceforge.net/cgi-bin/blosxom

  • dead_red_eyes

    Oh come on Adrian, is that all you got?

  • http://www.createdigitalmusic.com Peter Kirn

    Actually, I think the proper Mac fanboy response would be aome jab about not running Windows.

    But we seem to be getting our fair share of Microsoft and Apple both being evil to us. Can we, uh, stop that now, maybe?

  • velocipede

    Apple is not evil. Steve Jobs is evil. Look at the black turtlenecks. Isn't it obvious? har har.

    As a corporation, the question they have to answer is: what will make them more money?

    Maybe they will sell Bootcamp as a separate product for $300 and it will come with Vista when Leopard comes out? Probably not, but they must be considering their options for both short and long term profit. User feelings and convenience are only parts of the equation.

    Same issue with the iPhone update, I think.

    Too bad corporations aren't obligated to balance their customer and employee needs with their shareholders. They only do so when forced by law or to build brand value (which should contribute to the bottom line). Otherwise they are obligated by law to serve their shareholders by making as much money and growing the value of the company as possible.

    But, maybe Apple will take Peter's advice and let people use BC on Tiger a while longer. After two missteps with the iPhone (price drop fiasco and recent update), they might want to lower the jerkiness ranking a little to maintain their image.

    Maybe if every Apple product user also bought a share of Apple stock, we could band together and cut back on anti-user behavior.

  • http://www.createdigitalmusic.com Peter Kirn

    Hey, I think "will it make them more money" is exactly the question they should be asking.

    Did all those years of constricting features in QuickTime Pro and getting a trickle of income make them more money in the long term? Hmmm… with everyone watching videos in Flash, I wonder about that. (That isn't the fullscreen issue alone, but what happened to those $30 fees in the long run?) This seems like a parallel decision: try to use some basic functionality as a means of milking more money out of the customer. And Apple should know better than that, partly *because* they've got such a great story to tell with Leopard. Shutting out existing users doesn't tell that story very well. If it's, say, a beta of an application, that's one thing, but being locked out of a Windows install on your machine is likely to have a bigger impact on people. And it seems like in this case, while I understand the rationalization, they don't have to do this.

    It's well worth taking these decisions with a grain of salt, and looking at the larger context — and I fully expect the larger context with Leopard to be very positive. But I think that means it's all the more important for us to gripe about things that don't make sense. And sometimes, big companies do listen — especially if people are griping loudly when it's called for. I will say, Apple has often been very receptive to input, at least on some issues.

    And I'm not just pointing this out to criticize Apple, anyway, as I'm sure you know. The main thing is, existing Boot Camp users are going to want some advance warning before they've got a non-bootable OS!

  • http://www.createdigitalmusic.com Peter Kirn

    Actually, it occurs to me as well that we're getting away from the real point:

    The point is not that this is philosophically bad. The whole reason I'm putting this on CDM is that a lot of Mac users *won't be able to* upgrade to Leopard on day one. It shows real lack of understanding of the compatibility picture to say the *second* Leopard ships, you should upgrade. Now, Apple has been the last company to worry about compatibility, but this is still a factor. Take the Logic (and Final Cut, for that matter) user bases — they're still often reliant on third-party products that may not be ready.

    So, this isn't a philosophical matter; it's a practical one.

  • R Eunson

    From ITWire

    "Beta version 1.2 expired on September 30, while 1.3 and 1.4 last until the end of 2007 or the release of a commercial version. Boot Camp will be part of Mac OS X 10.5 (Leopard), which is due this month, so the latter is likely to be the operative clause.

    The good news is that an existing Windows installation will keep working happily. Although people talk loosely about using Boot Camp to dual-boot Mac OS X and Windows, the Boot Camp software is only used to take care of the partitioning, installing the operating system and preparing device drivers.

    So anyone that used Boot Camp beta 1.2 is still fine, as long as they don't need to go through the installation process again – the Boot Camp Assistant in version 1.2 no longer works. Given that more recent versions featured better device drivers and other improvements, there's no real reason to still be using 1.2."

    The above article is completely wrong, you can take as long as you like to upgrade to Leopard, you won't be left with a non-bootable OS.

    Only the BootCamp assistant stops working.

    Since setting up the BootCamp drive on my Mac I haven't required BootCamp assistant.

    Do some research before posting.

  • Cloud

    Don't you guys read? Please, be fair. Apple has said all along that the current version of Boot Camp is time-limited BETA (that word alone should give you a hint).

    Apple has already extended the license to accommodate the delay in shipping Leopard and now the time is up.

    If you need Windows, put Leopard on another drive or clone until the bugs are worked out. It's not the end of the world.

  • http://www.createdigitalmusic.com Peter Kirn

    R Eunson, that's helpful; thanks. Too bad Apple couldn't release the same information.

    In fact, me being "unfair" (Cloud) and not doing "research" (R Eunson) amounts to this:

    * Putting user needs in front of user license agreement legalese

    * Trying to figure out exactly what's going on from an Apple support document that seems purposely vague (and does NOT say what that ITWire story says, though I sure hope the ITWire details are accurate)

    So, you're welcome to continue using Boot Camp, except you're in violation of your user license?

    And I *absolutely* stand by my headline. Until we have Leopard in-hand (now that it's half a year behind schedule so that, by Apple's own admission, they could finish an unrelated product some Mac users don't necessarily want), plus third-party drivers, then Tiger + Boot Camp is the solution.

    Let me be clear: I'm here to represent the user perspective. Apple may well be making smart business moves. At the end of the day, though, the story I tell — with Apple or anyone else — will be how that impacts the end user, namely the musician. It's my job to do that, just as it's Apple's job to communicate their perspective. (And in this case, their position seems awfully vague — this isn't just an app, it's whether or not you can boot another OS, just at the time when Apple is presumably trying to make its end users comfortable with that concept.)

    Like I said, it's a small detail, and nothing to get overly worked up over, but I do think it's worth pointing out.

    So the one thing I'll revise: Apple, maybe at least a *clarification*?

    And yes, for the record, I'm still looking forward to Leopard.

  • Damon

    Nothing says freedom, like do it or else. I just had the fuel injection tuned up in my car, now my car has expired. I can keep the fuel injection, but i have to update the rest of the car….

    Sorry, recently downloaded the new Steven Wright comedy album, "I Still Have A Pony," now on iTunes…

  • bliss

    Peter Kirn for President! :)

  • http://www.midisticks.com Andrew Cordani

    I was intending to upgrade to Leopard – I knew that the BootCamp install was time limited – It was free after all.

    I wouldn't consider it a problem – but I'd be very happy if there's some way to continue using the XP install / stuff installed under it / partition / data AND 10.5 comfortably (reliably) installs over 10.4, AND doesn't eat up what space is left, AND all my applications still run ON both XP and OSX (i.e. they haven't broken anything).

    Not much to ask, really.

    Let's hope it's not a case of an upgrade that kills your machine.

    (Peter Kirn for Galactic Coordinator!)

  • czman

    peter, with all due respect, most of your article has been pointed out to be wrong. a half-assed clarification which blames apple for being un-clear seems like a rationalization to me.

  • http://www.createdigitalmusic.com Peter Kirn

    czman, nearly all of the article was and is correct. I said you'd need to upgrade to Leopard when Leopard was released, because Apple said "the Boot Camp Beta program expires when Mac OS 10.5 Leopard becomes available publicly in October, 2007". And I see that as a problem, because I doubt my advice to musicians will be to run to their Apple Store the day Leopard is available so they can install the new OS the same night on their primary music creation computer:

    * The software is in fact expiring upon release of the new OS, according to all sources. Apple didn't say exactly how this would occur in the case of the 1.3 / 1.4 beta, saying only the "license" would expire, you can't use the software, and need to upgrade to Leopard. And yes, the boot loader *should* continue to work, possibly minus the assistant (that's unclear). But here's what Apple has to say about that, in their words:

    "The license to use Boot Camp Beta expires when Mac OS X 10.5 Leopard is available to the public. To continue using Boot Camp at that time, upgrade to Mac OS X 10.5 Leopard."

    I think it's pretty clear that they wanted me to read this as I did: you'll need to upgrade *when* Leopard is available if you want to dual-boot.

    I translated that as "the software will expire", as did a number of other writers, and as I expect users might, because it's in a support document that otherwise details software expiring (Boot Camp Assistant beta 1.2 and earlier).

    I think that was incorrect, so I corrected it — twice in the article, and a third time in comments.

    But I don't think it's a "rationalization" to criticize a support document entitled "When does Boot Camp Beta expire?" that avoids the question of when Boot Camp Beta expires and doesn't explain fully what "expires" means.

    * R Eunson I believe misread the ITWire article. It does NOT say the beta will last until the end of 2007, it says the end of the year or Leopard's release, whichever comes first (and Leopard should definitely come first):
    http://www.itwire.com/content/view/14692/53/

    Anyway, we're splitting hairs. My point is that an operating system update is different than an application update. An application you would expect to expire the day the new app is available, because it's easy to update. An operating system is a different beast.

    For comparison, Microsoft's Vista beta expired May 31, not January 31 when Vista got its commercial release. Some kind of grace period clearly makes sense.

    Okay, now, some people might say Vista beta is still going on, but that's a different can of worms. ;)

    Oh, and one other clarification: I haven't yet announced whether I will be running for Galactic Coordinator.

  • http://www.createdigitalmusic.com Peter Kirn

    Oh, and just so I'm totally clear, the consensus I'm hearing (even if left out of the support doc) runs something like this:

    * Your license expires when Leopard ships, but Boot Camp was unsupported beta software anyway.

    * The bootloader — the screen that lets you choose between operating systems — should continue to function.

    * The assistant for beta 1.4 will cease functioning, apparently at the end of 2007. Presumably 1.4 beta had the baked-in new expiration at the outside date, 12/31/07, just as earlier versions had their egg timers set for September 30 (the day Apple posted the support update).

    So, I don't want to get carried away: the practical upshot is, yes, you can keep running your dual-boot setup. You just have to ignore what Apple tells you to do and run the setup anyway, upgrading to Leopard on your own darned time. Like I said, just keep those lawyers away from your desk.

  • czman

    I understand your points. thanks for clarifying.

    The thing is it was very easy to misunderstand your post and to assume that All those windows partitions that people use these day would suddenly become "bricked" come leopard – and that does not make any sense, as the evidence does not support this.

  • http://www.createdigitalmusic.com Peter Kirn

    Absolutely, and the fact that they're *not* bricked is a huge relief for everyone… maybe worth a separate post.

  • velocipede

    Christopher Breen also sees an anti-user trend in Apple behavior, though he does not mention Bootcamp.

    http://www.macworld.com/weblogs/editors/2007/10/a

  • Kyran

    Basically what the statement means is that it will still work, (until the end of 2007), but that you are not allowed to do so.

    So in legal terms, they are locking you out of your windows install.

    They are forcing you to break the law to keep your system working as is, with no grace period.

    That is not a customer friendly way of working in my book.

  • http://www.createdigitalmusic.com Peter Kirn

    Hmmm … I'm not sure I'd lump together the things Chris has put together in that article. A recessed headphone jack is just a lame industrial design decision. Aesthetic problems with Leopard? Well, hey, no matter how badly they design the dock, you still don't want to see my Vista usability list. And that's still an aesthetic problem. (Does anyone really *like* the dock? At least it's more usable, if slightly uglier, in this version.) Ringtone policy?

    But none of those are really the same as the policy toward users and technology. Then again, that's kind of the problem if you try to generalize. Just my own feeling.

    I think there are some patterns in terms of bricking iPhones, locking out developers, etc., and that I find a little more alarming, but not directly related to this Boot Camp issue.

  • velocipede

    True, Peter. It's kind of a kitchen-sink full of complaints. (I do think the recessed headphone jack is too obvious for Apple's designers to not have known what they were doing.)

    Hey, maybe Leopard will be sold with a Bootcamp that could still be installed and run on Tiger? Surely Apple could do that if it wanted to. That would be fair to Tiger Bootcamp users who don't want to upgrade their machines to 10.5 right away.

  • Andrew Cordani

    Installed Leopard today – Well I'm almost over the moon!

    The New XCode's a bit crashy (on some builds – I haven't spent much time looking at why) – but Bootcamp (new drivers) still work (XP) – and Everything I've tried (OSX) so far seems to work – so Yay – everything I could have asked for! :)

  • Pingback: Danny The Monkey King » Blog Archive » Apple and the overuse of pesticides