Our sources tell us some of you have run out to buy Mac OS X Leopard on its debut evening. If so, do be sure to tell us what’s working or what’s breaking.

Our initial reports have told us just about all software should be compatible, including plug-ins. Hardware should work too, generally, though we’ve gotten a couple of anonymous hardware manufacturer reports that suggest you may see updated drivers. The good news is, people I know running Max/MSP/Jitter haven’t had any issues at all; usually Max has compatibility problems with PACE copy protection drivers, as it did initially with Vista, until an update is available (usually within a few weeks). This means iLok copy protection should work, too. But, of course, I’ll believe it when I hear it, and you’re out in the field.

One other question: is upgrading frying any of the authorizations for your copy-protected music software? If so, which stuff?

And no, I’m not upgrading yet. The temptation is all on the visual side, with Core Animation and the new Quartz Composer, so I expect I’ll give in soon.

  • http://www.badassembly.com Scott

    So far so good here. Logic / Live / All plugs functioning as they should.

  • parma

    looks like there are problems with some NI stuff:
    http://www.native-instruments.com/index.php?id=le

  • endekks

    I have problems with net connectivity in general, so I'm not certain how far I want to explore potential issues with my audio software.

    And problems with NI software? No way! NI is always so prompt with updates for recent Mac OS releases. [/sarcasm]

  • http://amoebafunk.com amoeba

    macbook, live, m-audio & mackie FW interfaces – all going well. still pounding on things, but overall… more impressed than i thought i would be! very responsive! i will report back after some deeper testing.

  • Simian

    enddekks make sure if you are not using DCHP you set your DNS as the ip of your router (I noticed alot of people were not doing this including and the net does not work if you dont) :) Anyway Its very good, stacks are usefull, I have made folders with alias's in (audio apps in one, development apps in another), and used them as stacks which is usefull :)

  • Trademark

    I use a Core Duo Macbook. Upgrade install went smashingly well. I use Reason 4 and SuperCollider. Reason works fine, no serial resets or anything. SuperCollider mostly works, but may have some issues with input devices, but thats just getting obscure…

    Leopard is great!

    TM

  • KW

    I've installed Leopard on a 2GHz MacBookPro. After a few hours use, I have found no issues with MaxMSP, Reason 3.5, Logic Express 8, Spectre, Audio Xplorer or SignalScope Pro. Soundflowerbed causes a buzz if an app's audio routing is changed from while Soundflowerbed is active but this is easily solved by switching Soundflowerbed from built in output to off and back to built in output again.

  • samu

    Live fine. NI AK1 drivers not working. New machine, though, and I haven't got round to installing anything else yet anyway.

    A sensible move would have been to clone Tiger onto an external disk to use until everything was Leopardable. Strangely enough, I knew this even while fnot doing it. I don't understand myself sometimes.

  • http://www.createdigitalmusic.com Peter Kirn

    I don't think it's quite fair to trash NI without knowing the source of the issues. As you'll notice, many people are having no issues with unpatched applications — meaning those applications, for whatever reason, got lucky and didn't run into a problem. Despite the iPhone delays, I generally have heard developers of all stripes (not just music) have run into plenty of problems even in the past couple of weeks. It's just the nature of the beast; this stuff is unpredictable, and Apple was making adjustments right up to release.

    The other implication: there may be other issues we discover over the coming weeks. So keep those bug reports coming, and I'd still be careful about switching a critical machine to Leopard.

  • http://www.createdigitalmusic.com Peter Kirn

    Ah, reader reports from Chris over on our previous story:

    "My M-audio Ozone keyboard is no longer detected under 10.5 on a 1.5Ghz Powerbook. I did an archive and install, and reinstalled the drivers (says 10.4.9 PPC) but nothing.

    Just going to echo Jason and say hold off until there are new drivers and you know stuff will work."

    Yep, ditto. Truth is, my sense is you can just wait a month or two and let the updates come in.

  • Greg Kucharo

    No issues here with Reason 4.0, Live 6, Max/MSP..

    Plugins that seem to work so far:

    CamelSpace

    OhmForce Hematohm, QuadFromage

    Most of the Pluggo plugins

    Daevl plugins

  • http://www.curved-air.com actuel

    absolute no issue's here. macbook pro, ableton 6 (beta 7), max/msp, and a litter of plug-ins.

    easily the smoothest update i've experience thus far since 10.1.

  • http://www.myspace.com/tricil tricil

    everything's fine here except for discWelder bronze (it was a PPC application anyways) that came with my FireBox (which also works) and uses the PACE support to make the FireBox a dongle (it since has been broken)

    $50 down the drain for that, but I could download a patch from the interLok site… if i cared.

    Live, Battery, and even Peak Pro (which bias said wouldn't work) work.

    Time Machine, however… Is giving me a ginormous headache, and NOT working over my eSATA expresscard with the Sil 3132 chipset (I know it says FireWire or USB, but if it can read and format eSATA, it should work)

  • http://www.precious-forever.com Christophe Stoll

    Everything works pretty fine here so far, it even feels faster/more fluid to me (tested Live 6 and Logic 8, opened different songs with several plugins such as Reaktor 5, Absynth 4, Battery 3, OhmBoyz, …). Going to do some deeper testing seen and report back here (my AK1 is in the studio).

    The only thing I noticed so far, but I'm not 100% sure if I'm erring, is some weird behavior within "Lucifer", one of my favorite plugins. Maybe I remember wrong, but I think there was only one position bar (black) in full height for the buffering position, and the actual playback position was indicated with a tiny red rectangle below the display (which does not move anymore). But thats something reallllly harmless and, as far as i know, there will be no updates to Lucifer anyways, so it doesn't really make sense to wait :-)

  • veggieryan

    yes,

    I am VERY impressed.

    In my case a straight upgrade didn't work… live 6 would crash on start up.

    I made a choice to do a fresh install and manually reinstall all my apps.

    This turned out to be a great decision as my whole machine was cluttered with apps I did not use.

    1. Mail.app is much improved in every way.

    2. Finder is now amazing. Fast and solid. Spotlight seems snappier too.

    3. Everything is just layed out with care.. the download stacks are a great idea.

    4. spaces takes some getting used to…

    5. overall performance is much much improved.. kudos apple.

    6. compared to the vista release… wait.. there IS NO COMPARISON!!!

    7. pretty much everything just works.

    8. my saffire pro 10i/o seems to loose its mind more often.. but its firewire so it inherently blows. thank god that the new RME express card is coming to rescue us all from firewire hell.

    9. firefox seems way faster now.. but maybe thats just me…

  • http://luxvibes.com augmentalist

    Not so good. When I attach an external monitor/projector to my MacBook, the system begins to hang every 8-10 seconds, the mouse gets all wacked out and the system will no longer reboot even if i remove the AV dongle. This

    is a tragic event for me. I use my projector

    every day and essentially the Leopard upgrade

    has ruined my AV setup.

  • MonksDream

    Smoothest upgrade I've ever done in 15 years in IT. Everything works EXCEPT my M-Audio FastTrack Pro. The system sees it just fine but no audio at all. Other than that everything works (Logic Express 8, Live, many and various plugns).Time Machine alone is worth the price of the upgrade.

  • Andrew Cordani

    BFD from Fxpansion seemed fine on a cursory test.

    Plogue Bidule 0.95 hung when I first tried it (while deleting an audio bidule) I then installed 0.96 (just released) and that seems fine so far.

    Some problems building applications (XCode3) across networks – Build process hung to the point where all I could do was re-boot – only to find the machine wouldn't come back up properly (Caught in an endless loop of giving user details!) – Eventually I reinstalled it from scratch – Am now in the process of reinstalling everything :(

    {Mentioned previously on the forum}

    Boot camp ASIO4ALL still works beautifully – as do all the apps I've run under it with the new drivers.

    Leopard Overall about 80% content (100% content with Bootcamp, so far).

    {Disclosure, fan, evangelist, and friend of Fxpansion.}

  • http://www.myspace.com/arudiuskil Nathan Kil

    Re: To Christophe Stoll: I had a short dialogue with the creator of Lucifer after emailing him and asking him about any updates. You might be interested to know the following from him:

    "I will sell currently who already understand the product and don't need a lot of near-term support (paypal steve@duda.org $99, for existing 2.1 version and lifetime free updates). Upside for doing that is Lucifer will likely be repriced to $129 when 2.2 is out.

    my best estimate is September for 2.2 and public launch, I need to get some proper testing on v2.2 as I've added a lot of features and need to get our website up and running (www.xferrecords.com). "

    That was from Steve Duda, the creator of Lucifer. Thought you may want to know. :-)

  • http://www.precious-forever.com Christophe Stoll

    Hey Nathan! Thanks for the hint, i'll get in touch with Steve. Maybe you should remove his email address here (or change it to xyz [at] xyz [dot] com), if you can still edit the comment. Spam spiders suck! :-)

  • MonksDream

    Update to my previous post. The FastTrack Pro interface is working perfectly! It was a cabling problem. Go fig…

  • Hank Spaniel

    Everything worked well initially but now having trouble with my M-Audio FW1814. It's trying to update the Firmware and causing kernel panic (reboot required). Bummer. Ableton Live, Logic Express, NI Guitar Rig, NI Traktor all working fine though. I like the Leopard interface, lots of very useful goodies – switched over to using Mail from Thunderbird since now the interaction and interoperability between Mail and iCal is very slick.

    Hoping for new drivers from M-Audio very soon… ;-)

  • Hank Spaniel

    Sorry – just one thing. If you're using Logic, SWITCH OFF SPACES while using it… CTRL+arrow keys are bound to spaces, not zooming in Logic.

  • http://amoebafunk.com amoeba

    only busted thing i have is the driver for my midisport8x8. my FW410 has no problems. axiom49 and bcr2000 controllers work just fine, as well my mackie onyx w/FW card (but the last 3 are all class-compliant).

    i have a feeling the midisport will be low on the m-audio list, but at least my FW interface is fine.

  • http://amoebafunk.com amoeba

    addition to above: 8×8 via USB is broke – but works fine via midi cable.

  • Garry Schafer

    I can't get ableton to launch at all. KILLING me.

  • Michael Blanchard

    I have the same problem as Peter Kim with my m-audio ozone MIDI device not being seen in Leopard, this time on 2Ghz Intel Core Duo iMac. I also downloaded the latest drivers from m-audio (which are for OSX 10.4.9) to no avail. Hoping for an update soon.

  • grimley

    Some serious (and confirmed by NI) issues with Reaktor. Certain confirmation/warning dialogs can hang the app and require a "Force Quit". A few graphicsl glitches too … connecting lines can vanish etc.

  • j!M

    Anybody figure out the M-Audio Ozone not being seen? My Live, trigger finger, x session, and fastrackpro are working fine.

  • http://www.nextcat.com/davidgriffiths dave

    Also no joy with my ozone keyboard. Icon for the device is still there but it doesn't recognise it.

  • Zem

    Does anyone know of a way to get M Audio's Ozone midi/audio keyboard to work with mac OS X Leopord 10.5? The website for M Audio offers no help in the way of compatible drivers (suprised !!) you'd think with everyone making drivers for leopord OS X, that they'd wanna keep up, i mean this is laughable. only i aint laughing. if anyone knows of a work around please let me know.

    Daniel

  • Nick

    Same problem here with my Ozone.. Triggerfinger works fine. I'm very disappointed in M-audio for their lack of professionality. it sucks having to depend on their lazyness!

  • james

    Someone posted this fix on another site:
    http://namedfork.net/midisportloader

    Not worth it for me but it took a lot to use M-Audio gear from the beginning and then when I break down and go that way after so much praise and support from Apple they do not even support the large number of users.

    This sets them way back in my list of brands to trust. Torq was bad enuf but not having drivers ready when they had over 7 months to code them.

    Substandard. It's December M Audio, did you close up for the holidays?

    jt

  • Daniel

    cubase sx 1.0.4 isn't working. it starts opening, but then freezes as it gets to vst. most frustrating… does anybody know of any fixes?

  • http://www.brettsongs.com Brett

    I've been elected to be the local canary in the coal mine with Logic, Waves, FW audio interfaces etc.

    I'm not a PT user but I gather they'll need to wait a few months.

    FW interfaces: so far no problems with MOTU 828mkII and their update, some problems with PreSonus Firebox being recognized (trying the v2 firmware update just in case), not expecting much any time soon with M-Audio 410 which is a noisy little unbalanced beast anyway.

    Plug-ins: Waves is attracting lots of negative comments and hopefully will get their act together in a few months. The whole which WaveShell and Logic only likes one WaveShell and different 5.x versions was always pretty annoying before. Supposedly 5.6.1WS fails AU validation for some but not everyone?

  • http://powlow.eu powlow

    I've got the same conectivity problem with an M-Audio Ozone. Its really the only problem I've noticed upgrading to Leopard. Hopefully the new drivers will be out soon and will bring something more than just Leopard compatibility (well it IS xmas and you're allowed to make wishes)!

  • Bao

    Good News!

    I have the M-Audio Ozone also and was disappointed that it stopped working under leopard.

    As an experiment, I just installed the new M-Audio driver for the Oxygen8 (3.2.3) and it's actually working for the Ozone too.

    I have a feeling the real Ozone driver will be out pretty soon. But, I suggest using the Oxygen8 driver as a temporary solution for those of you who have the Ozone.

    Merry Holidays. :)

  • Chongo

    @BAO – Just tried that myself and it does NOT work on a Dual 1ghz Quicksilver.

    ohh well.

  • Disappointed

    I had a strange situation with my Ozone under Leopard. I installed the drivers and it worked for about 2 weeks. I rebooted my machine one day and suddenly recognition of the audio device vanished. I reinstalled the drivers to no avail. M-audio used to be the most proactive with respect to Mac OS X of any of the audio interface companies. Now that they are owned by the unprofessional, my way or the highway, Avid/Digidesign, I think we can expect "old" gear to get orphaned quickly.

  • http://www.myspace.com/milingosutera macmilingo

    someone have installed the new ozone drivers for leopard? they work?

    my ozone still work with midisport loader drivers(i dont know how but it works more or less),and i'm not sure to change now for new drivers…

    help please a real noob :)

    thankz.

    p.s. i want to thank the creator of midisport loader, he saved my life! ;)

    this is the link reposted to midisport
    http://namedfork.net/midisportloader

  • http://www.myspace.com/milingosutera macmilingo

    uh,the last thing…;)

    my pro53 (UB,DYNAMICS) is not recognized by logic and ableton live, but it works in standalone mode,

    someone knows why or how to work with those softwares?

    thank you.

    p.s. all the rest of the softwares (logic,ableton,garageband etcetc works well with leopard)

  • coco

    why live 6 not working in imac after installing osx 10.5 ???can ny one help me?plz