snow-leopard-boxMOTU did not respond to CDM’s inquiry regarding Mac OS X 10.6 – but they have just posted the most interesting update I’ve seen yet. They have drivers ready for their hardware today, and (nearly) full compatibility for their entire product line. They also suggest that 64-bit support is in the works for their applications, which would make MOTU the first audio software developer I’ve heard even breathe a word of discussion of 64-bit. I couldn’t even get a solid commitment to 64-bit from Apple’s Pro Apps folks (though Apple tends not to talk about things until they’re done). The appeal would be clear – MOTU could give their sampling apps access to greater memory.

MOTU has a comprehensive update page, and I’ve added the news to the http://createdigitalmusic.com/snowleopard round-up page.

That said, while MOTU has the greatest level of out-of-the-gate support I’ve seen from any vendor for 10.6, even they have run into a showstopper issue. Their Ethno Instrument isn’t yet compatible; an update is expected. Sure, that’s just one instrument. But the lesson here? If you don’t mind the occasional wrinkle, you can live on the bleeding edge. But if you want to keep your software up and running, your best bet is to be patient and wait to upgrade. That’s not to discourage you from testing the latest-and-greatest, it just means you need to have the expectations to match.

The news remains, though: MOTU does have updated drivers for those of you with MOTU hardware or software who want to get a head start on setting up Snow Leopard.

That does not seem to be the case with other hardware vendors (Pro Tools, M-Audio, Tascam, and PreSonus all suggest waiting), and even some of the drivers that will initially become available should be considered “beta.” That is, they may even be designed to work with 10.6, but could use additional testing. I think that could probably generally be said of this update for musicians – just as with any significant operating system update on any platform.

  • Kewl

    "They also suggest that 64-bit support is in the works, which would make MOTU the first audio developer I’ve heard even breathe a word of discussion of 64-bit."

    Not exactly. See I'm using their 64-bit driver right now.

  • Kewl

    Let's try that tag again…

  • Kewl

    It's not working as expected… That URL is in my first comment.

    P.S. It would be nice to preview comments…

  • viik

    Anyone knows the compatibility of the Play Engine? (east west, quantum leap orchestra gold)

  • kipplekeeper

    I'd like to add that RME's current drivers are rock solid in 10.6!

  • John

    I just installed MOTU's 10.6 driver for PCIe 424 and it hangs the system. Don't install it until MOTU releases true 10.6 drivers.

  • Jazz

    For those having trouble with the motu driver under Mac OS X 10.6 Snow Leopard try this:

    http://discussions.apple.com/thread.jspa?messageI

    Cheers,

    Jazz

  • http://www.titanlineaudio.com Houston Haynes

    Ahem – Steinberg not only breathes a word about 64-bit support for the Mac, but also publishes a specific time line. Just sayin'.

  • Pingback: rmes